Headlight not working

Post your G Series Technical Q&A's here

Moderator: Moderators

User avatar
RogueAssassin
Forum User
Posts: 15
Joined: Sat Jun 30, 2018 8:42 am
Country of Residence: Leicester

Headlight not working

Postby RogueAssassin » Sat Jun 06, 2020 11:31 am

So having a few issues with my Bmw f800gs 2009.

The bulb went on my headlights so I replaced it with a working bulb. The main headlight now no longer works and my cluster is saying bulb warning.

I have tried multiple working bulbs and nothing. Yes the engine is running and still nothing.

I understand that there is no fuses on the gs so how would I fix this issue?

Any help would be great.

Thanks

Amy


Sent from my iPhone using Tapatalk

User avatar
george baker
Club Member 13
Posts: 8243
Joined: Mon Aug 01, 2005 10:51 am
Country of Residence: uk
Location: Manchester,UK

Re: Headlight not working

Postby george baker » Sat Jun 06, 2020 1:27 pm

Hi
is it CAN bus? Does the ECU need to be told about the lamp?

George
Member 21, R100R, and an under used K75

User avatar
RogueAssassin
Forum User
Posts: 15
Joined: Sat Jun 30, 2018 8:42 am
Country of Residence: Leicester

Re: Headlight not working

Postby RogueAssassin » Sat Jun 06, 2020 1:28 pm

Hi
is it CAN bus? Does the ECU need to be told about the lamp?

George
Everything I am reading online is leading me to believe that it is CAN bus.


Sent from my iPhone using Tapatalk

Mike D
Forum User
Posts: 1869
Joined: Thu Oct 18, 2007 3:12 pm
Country of Residence: UK
Location: Near Daventry, UK

Re: Headlight not working

Postby Mike D » Sat Jun 06, 2020 2:32 pm

If the 'Lamp fail' was only illuminated after the original bulb failed, and your dip beam is still working, then it appears that the replacement bulbs are drawing too much or too little current which the control module registers as a fault and closes down that circuit.

Does your headlight use a combined main/dip bulb, or do you have a separate headlight for each function?

Do you have access to a fault code reader (like a GS--911) to try and reset the lamp fail (even though it should reset itself with a new bulb).

P.S. Your bike is an F series not G series so perhaps a moderator could move it to the correct location.

Mike

User avatar
windmill john
Forum User
Posts: 4710
Joined: Fri Feb 18, 2011 9:58 am
Country of Residence: England
Location: Somewhere in Southern England. bip bip bip, loose lips sinks ships

Re: Headlight not working

Postby windmill john » Mon Jun 07, 2021 12:55 pm

Interesting thing I learned about the F800GS and possibly all Can Bus devices. If you rip out the dash completely, the bike runs fine. apparently each module is independant.
I only mention this as you said the engine is running. Engine running is not related to your issue.
http://www.kittos.co.uk
Best roads: 623 Burgos to Santander. A back road to Metz; can't remember which!
Tweety Pie, my F650GS
Si, my CX500
Too many bikes have come and gone, trying to be sensible now!

User avatar
george baker
Club Member 13
Posts: 8243
Joined: Mon Aug 01, 2005 10:51 am
Country of Residence: uk
Location: Manchester,UK

Re: Headlight not working

Postby george baker » Mon Jun 07, 2021 11:26 pm

Hi
I wish I had known that can bus bikes did not need a dash to run cos I saw a G650 on ebay missing the clocks but did not bid cos I thought it would be a non runner.
George
Member 21, R100R, and an under used K75

User avatar
windmill john
Forum User
Posts: 4710
Joined: Fri Feb 18, 2011 9:58 am
Country of Residence: England
Location: Somewhere in Southern England. bip bip bip, loose lips sinks ships

Re: Headlight not working

Postby windmill john » Tue Jun 08, 2021 6:10 am

Can’t recall the article, but yes, there are three main ‘clusters’, the dash, engine management and something else! Very technical response.
All three run independent. Obviously the only one you need is engine management.
I think I tested it when I had my 800 by disconnecting the dash multi plug and starting.
I had a GS 911 at the time so wasn’t too stressed if things went south.
http://www.kittos.co.uk
Best roads: 623 Burgos to Santander. A back road to Metz; can't remember which!
Tweety Pie, my F650GS
Si, my CX500
Too many bikes have come and gone, trying to be sensible now!


Return to “G Series Technical Queries”

Who is online

Users browsing this forum: No registered users and 1 guest